Exchange 2007/2010/2013 Postfach zu bestehendem Nutzer hinzufügen funktioniert nicht

Problem

exchange2010-kein-userAuf einem Exchange 2007/2010/2013 lassen sich bestehende Benutzer nicht auswählen um Ihnen ein neues Postfach zuzuordnen. Die Benutzer werden in der Auswahlliste im EMC-Assistenten nicht mehr angezeigt.Das gilt für alle Benutzer, die schon mal ein POstfach zugeordnet hatte, seit Exchange 2003.

Das Powershell-cmdlet „enable-mailbox“ schlägt bei dem Versuch das Postfach manuell zu erstellen mit einem „Empfängertyp“-Fehler fehl.

[PS] C:\>Enable-Mailbox -Identity NAME
Dieser Task unterstützt keine Empfänger dieses Typs. Der angegebene Empfänger doma.in/OU/NAME ist vom Typ UserMailbox. Stellen Sie sicher, dass dieser Empfänger dem für diesen Task erforderlichen Empfängertyp
entspricht.
+ CategoryInfo          : InvalidArgument: (<CN>:RecipientIdParameter) [Enable-Mailbox], RecipientTaskException
+ FullyQualifiedErrorId : BB2B6FE5,Microsoft.Exchange.Management.RecipientTasks.EnableMailbox

Lösung

In dem Benutzerobjekt sind vermutlich noch alte und/oder veraltete HomeMTA-Attribute eingetragen. Die Exchange-cmdlets zur Benutzerauflistung lösend iese Objekte nicht auf, weil sie davon ausgehen der Benutzer hat bereits ein Maiulbox-Objekt auf einem anderen Server/in einem anderen Forest.

Die Benutzerobjekte lassen sich mit „Remove Exchange Attributes Tool – Version 1.0 – [11KB]“ (von telnetport25.comugg.li Download Mirror) entfernen:

RemoveExchangeAttributes.exe  <kontoname> remove

Das lässt sich auch gleich bei mehreren Objekten in einer TXT-Liste erledigen (Die Liste muss nur den Kontonamen enthalten, sonst nichts):

for /f %i in ('type liste.txt') do RemoveExchangeAttributes %i remove

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

*

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden .