Office365 Powershell Modul: „Sie benötigen Version 7.0 oder höher des Microsoft Online Serivices Anmeldeassistenten …“

sie-benoetigen-version-7-oder-hoeher
Problem

Das Office365 (=Windows Azure) Powershell-Modul lässt sich nicht installieren, mit der Fehlermldung: „Sie benötigen VErsion 7.0 oder höher des Microsoft Online Services Anmeldeassistenten, wenn Sie das Windows Azure Active Directory-Modul für Windows PowerShell auf diesem Computer installieren möchten“. Die Systemvoraussetzugnen (Powershell, Online Services Sign-in Assistant) sind in der korrekten Version installiert.

Lösung

Die Deutsche Version des Windows Azure Active Directory Module for Windows PowerShell (AdministrationConfig-DE.msi) liegt zwar in der richtigen Version vor, das Setup setzt aber den Registry-Schlüssel dafür nicht richtig. Die englische Version macht das korrekt, die kann man aber als Deutsches Admin nicht ohne weiteres herunterladen.

Abhilfe schafft der korrekte Registry-Eintrag:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSOIdentityCRL]
"MSOIDCRLVersion"="7.250.4551.0"

Dann läuft der Assistent durch. Nach der Installation kann der Wert wieder auf den Ursprünglichen zurückgesetzt werden (stand heute: 7.250.4209.0).

2 Replies to “Office365 Powershell Modul: „Sie benötigen Version 7.0 oder höher des Microsoft Online Serivices Anmeldeassistenten …“”

  1. ausnahmslos Vollidioten bei Microsoft. So viel geballte Unfähigkeit… der gesamte Laden gehört gerichtlich geschlossen.
    DANKE FÜR DEN BEITRAG!!!
    …Hätte ich den früher gefunden, hätte ich mir den Schaden von 1h Suche bei Microschrott sparen können…

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

*

This site uses Akismet to reduce spam. Learn how your comment data is processed.