Exchange 2010 will Datenbank nicht verschieben „MapiExceptionNetworkError“

Exchange 2010 (SP1) möchte seine Datenbanken schon mal nicht freiwillig verschieben, wenn man die interne URL der OWA/OAB Dienste auf http umgestellt hat (um Zertifikatsfehler|kosten|Umstand zu vermeiden). Die Fehlermeldungen dazu sind auch recht kreativ, vor allem in EMC und EMS unterscheidlich.

Meist liesst man solche netten Dinge:

Der Status von Datenbank "Mailbox Database 0110421406" konnte nicht abgerufen werden.
    + CategoryInfo          : InvalidOperation: (Mailbox Database 0110421406:DatabaseIdParameter) [Move-DatabasePath],
    InvalidOperationException
    + FullyQualifiedErrorId : 79FDD20B,Microsoft.Exchange.Management.SystemConfigurationTasks.MoveDatabasePath

In diesem Fall reicht es aus, den SSL-erzwingen Haken von der ECP-zugehörgien  IIS-Site zu entfernen:

IIS-Manager -> Site -> SSL-Einstellungen -> SSL Erzwingen Haken entfernen -> Übernehmen.

Dann eine Rauchen gehen oder anders etwa 5 Minuten Zeit vertrödeln. EMC neu starten und schon geht wieder alles. Das das NATÜRLICH nicht die goldene Lösung ist dürfte dem Lokalen Administrator klar sein, aber wer will schon für seine internen Sitehostheader extra Zertifikate beantragen oder eine extra-PKI bauen?

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

*

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden .