Exchange 2010 entfernt Mobile Geräte nicht „Das ActiveSyncDevice /ldap/xxxxx wurde nicht gefunden.“

exchange2010-activesync-removedeviceNachdem ein bestehender Benutzer umbenannt wurde, vor allem der Kontoname, lassen sich dessen verbundene mobile Geräte nicht mehr über die Outlook-WebApp oder die Verwaltungskonsole (EMC) entfernen. Sobald der Befehl ausgeführt wird erhält man die Antwort:

Zusammenfassung: 1 Element(e). Erfolgreich: 0, Fehler: 1.
Verstrichene Zeit: 00:00:00

BenutzernameDevicename

Fehler:
Das ActiveSyncDevice domain.local/OU/ALTER-Benutzername/ExchangeActiveSyncDevices/Gerätename 
wurde nicht gefunden.
Hier klicken, um die Hilfe aufzurufen ... http://technet.microsoft.com/de-DE/library/ms.exch.err.default(EXCHG.141).aspx?v=14.1.438.0&t=exchgf1&e=ms.exch.err.Ex0FBD0C

Ausführungsversuch eines Exchange-Verwaltungsshellbefehls:
Remove-ActiveSyncDevice -Identity 'domain.local/OU/ALTER Benutzername/ExchangeActiveSyncDevices/Gerätename'

Man sieht sofort, das die Konsole offensichtlich den falschen (alten) Benutzernamen verwendet. Der Hilfelink dazu ist natürlich genauso hilfreich wie fast jeder HIlfelink.

Lösung: Das Geät direkt an der Exchange Powershell (unter verwendung des richtigen Pfades) entfernen.

  1. Eine Liste aller Gerätenamen die mit dem Postfach verbunden sind erstellen
    Get-ActiveSyncDevice -Mailbox "Benutzer Name" | Select-Object Identity
  2. Das passende Gerät auswählen und entfernen:
    remove-ActiveSyncDevice -Identity "<pfad>"

exchange2010-activesync-removedevice-ps

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

*

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden .