Adobe Acrobat Reader DC Seitenleiste deaktivieren

ENDLICH! Nach dem Update auf Version 2015.017.20053 (oder höher) lässt sich diese nervige Werkzeug dauerhaft deaktivieren. Standartmäßig ist die Leiste bei jedem öffnen eines PDF Dokumentes offen und muss via ALT+F4 geschlossen werden.

Bearbeiten -> Voreinstellungen (STRG+K) -> Dokumente -> Werkzeugfenster für jedes Dokument öffnen

adobe-reader-werkzeugleiste-ausblenden

Java auf Switches „Zertifikat konnte nicht validiert werden. Die Anwendung wird nicht ausgeführt“

Problem

Brocade SAN-Switches (Hersteller von FC-Switches von HP, Tarox, Metadata, IBM und vermutlich noch vielen anderen) funktioniert der dämliche Java-Webstarter nicht mehr. Die älteren Geräte haben entweder gar keine oder abgelaufene Zertifikate und man sie des öfteren diese Fehlermeldung:

Anwendung zur Sicherheit blockiert
Zertifikat konnte nicht validiert werden.
Die Anwendung wird nicht ausgeführt.

java-zertifikat-konnte-nicht-validiert-werden

Lösung

Die schnellste Möglichkeit ist, das Konfigurationsapple direkt und ohne den Webstarter aufzurufen:

C:\Windows\System32\javaws.exe "http://<ip-adresse>/switchExplorer_installed.html"

Die umständlichere, aber länger anhaltende Möglichkeit ist das Java anzupassen:

  1. Im Verzeichnis der Java-Installation
    C:\Program Files (x86)\Java\<VERSION>\lib\security
    
  2. Die Datei „java.security“ mit dem Editor öffnen
  3. Diese Zeile suchen:
    jdk.certpath.disabledAlgorithms=MD2, RSA keySize < 1024
  4. Anpassen:
    jdk.certpath.disabledAlgorithms=MD2, RSA keySize < 256
  5. speichern, schliessen, Java/Browser neu starten, fertig.

Erscheint nach der Anpassung immer noch eine Fehlermeldung wie diese:

Anwendung kann nicht gestartet werden.
Missing required Permission manifest attribute in main jar:

Einfach im Java-Applet in der Systemsteuerung > Java > Tab „Sicherheit“ > Button „Sitelist beabeiten“ die entsprechende URL (http://<ip-adresse>) hinzufügen.

java-anwendung-kann-nicht-gestartet-werden

Outlook 2011/2016 für Mac fragt immer wieder nach Benutzername und Passwort

Problem

Microsoft Outlook für Mac 2011 und Outlook für Mac 2016 fragen bei der Anbindung an einen lokalen Exchange-Server (Exchange 2007/2010/2013/2016) immer wieder nach Name und Kennwort („Benutzernam eoder Kennwort falsch), obwohl die Eingabe ganz ganz ganz sicher richtig ist. Egal ob man sich mit „benutzername“ oder „domäne\benutzername“ oder „domä.ne\benutzername“ anmeldet – es wir immer wieder nachgefragt. Spannenderweise kann das Adressbuch aber mit den selben Daten problemlos synchronisiert werden.

Lösung

MacOSX hat seit 93 Äonen einen Bug im Keyring, der dafür sorgt das alle Benutzerdaten vor dem „\“ (Slash) entfernt werden. Man fügt also einen zusätzlichen slash ganz an am anfang des Namens hinzu und schon läuft wieder alles ..

\Domä.ne\Benutzername

Diesen Slash einfach hinzufügen.

Der Webdesigner sagt nein. Können Sie das stattdessen?

marketingfrau-quad-facepalmMarketingabteilung eines KMU Kunden.

Marketingfachfrau: „Haben Sie [admin] einen Moment Zeit? Ich habe schon mit den Internetfuzzies [kompetente Webagentur] gesprochen, aber die sagen die könnten das nicht“.

admin (schon skeptisch): „Ich kann ja mal schauen … worum geht es denn?“

Marketingfachfrau: „Ich habe den Laden in [Franchise-Standort] online angeschaut und das sieht FURCHTBAR aus. Können das schnell austauschen? So einen häßlichen Eindruck wollen wir nicht machen.“

admin, verwundert weil es keine eigenen Franchise-Webseiten gibt: „Äh, hmm, ok, können Sie mir das kurz zeigen?“

Marketingfachfrau „Na klar!“ und klickt die Straßenansicht mit dem Ladenlokal in Google-Streetview an …

Swyx Weihnachtspost

Das Swyx die aktuelle Referenzklasse der KMU-VoIP Implementierung darstellt ist praktisch unumstritten. Die Swyx-Weihnachtspost hingegen war etwas seltsam. Immerhin können wir uns glücklich schätzen, das Swyx die ausgehende Post (hoffentlich genau wie die eingehende) durch einen interspire-Filter schickt. Der in der Default-Config alle URLs mit mehr als einem Fragezeigen darin streng klassifiziert …

swyx_einmal-mit-profis

E-Mails per SMTP durch Speedport versenden geht nicht mehr

Problem

Seit dem Router-Tausch gegen einen neuen Speedport ist der E-Mail Versand via Mailprogramm (SMTP) nicht mehr möglich. Speedport-Router kommen in der Regel mit neuen T-Entertain-Anschlüssen oder werden bei der Umstellung auf VoIP verwendet. Von dem Fehler sind Port 25 und 587 (MQ) betroffen.

Lösung

Per Default ist in dem Router der Mailversand blockiert – ausser über die Telekom und deren (mehr oder weniger sympatische) Partnerunternehmen- und Töchter, wie beispielsweise 1&1. Die Funktion heißt „Liste sicherer Mailserver“. Im Speedport diesen Quatsch abschalten oder die „Liste sicherer Mailserver“ entsprechend erweitern. Diese rücksichtslose Blockade umgeht krass die Richtlinie zur Netzneutralität, indem Zugänge direkt im Endgerät blockiert werden. Wir finden das unglaublich dämlich, vor allem in der Defaultkonfiguration und prophezeien hunderte teurer Stunden der Fehlersuche. Möge dieser Artikel die kartellähnlichen Machenschaften des Konzerns offenlegen.

telekom-sichere-mailserver