vSphere Client auf DC installieren

Problem

Der vmware vSphere Client ab Version 5.1u1 lässt sich nicht mehr freiwillig auf einem Domänencontroller installieren. Versucht man das, erhält man folgende Ferhlermeldung:

„vSphere Client erfordert Windows XP XP2 oder höher. vSphere Client kann auf dem Domänencontroller nicht installiert.“

vsphere-client-auf-dc-installieren

Lösung

Aufgrund der Microsoft-Vorgabe „Always Isolate DC Role“, der auch grundsätzliche zuzustimmen ist, hat vmWare den OS-Check in den MSI-Wrapper eingebaut. Selbstverständlich lässt sich das (auf eigene Gefahr) auch umgehen. Der Client läuft auch stressfrei auf einem DC.

  • Plattform-Installer (~100mb) aus dem Globalen Installert (~350MB) befreien. Dazu einfach das Paket ganz normal aufrufen un den „viclient-setup.exe“ aus %temp%\{langeinummer} wegkopieren. Danach den Installer nach der Fehlermeldung wieder schliessen.
  • Den Installer aufrufen mit: viclient-setup.exe /VSKIP_OS_CHECKS=“1″

Update: Ein vmware Engineer sagt zu diesem Installer folgendes (Zitat):

We did this deliberately to enforce a Microsoft standard that our guys agree with – don’t install software on a DC, but they made that decision in isolation. Nothing more than that.  So use the workaround safely and hopefully we can undo this in the future.

4 Replies to “vSphere Client auf DC installieren”

  1. Pingback: vSphere Client auf DC installieren | Danky's Wiki

  2. Hat leider bei mir (vSphere Client 5.5) nicht mehr funktioniert, den Parameter hat er mir einfach ignoriert. Nach verzweifelter Suche bin ich auf eine Lösung gekommen:

    1.) Installer extrahieren wie beschrieben.
    2.) Extrahierten Installer starten, nach Start (und vor dem wegklicken der Fehlermeldung) das Verzeichnis mit dem MSI-File in %temp% wegkopieren.
    3.) Aus dem „redist“-Verzeichnis die vjredist64.exe installieren (bei x64-OS).
    4.) Die extrahierte MSI-Datei mit InstEd It! (Freeware) editieren, links nach „LaunchConditions“ suchen und die Zeile mit der Fehlermeldung löschen. MSI speichern und installieren.

    So hat es bei mir endlich funktioniert, ich hoffe das hilft jemandem, der das selbe Problem hat.

  3. @Ulrich: Du hast völlig recht. Der Parameter fehlt ab der 5.5er Release. Und dein Trick funktioniert tatsächlich: genau das habe ich soeben auch gebraucht und es hat wunderbar geklappt 🙂

    Vielen Dank, das macht mir grade einen guten Start ins Jahr!

  4. Pingback: HP Integrated Lights-Out 3 (iLO 3) funktioniert nicht im Internet Explorer und Firefox | Danky's Wiki

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

*